You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
buildsys-macros/buildsys-macros.spec

55 lines
1.6 KiB
Plaintext

# $Id: buildsys-macros.spec,v 1.2 2016/07/25 03:31:22 unnilennium Exp $
Name: buildsys-macros
Summary: Macros for the Fedora Buildsystem
# The value for version should match the version of Fedora Core.
Version: 8
Release: 3%{?dist}
License: GPL
Group: Development/Buildsystem
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Buildarch: noarch
Requires: rpmdevtools
%description
Macros for the Fedora Buildsystem
%prep
%build
%install
rm -rf $RPM_BUILD_ROOT
mkdir -p $RPM_BUILD_ROOT/etc/rpm/
VERSION=%{version}
printf %s%b "%" "rhel $VERSION\n" >> $RPM_BUILD_ROOT/etc/rpm/macros.disttag
printf %s%b "%" "dist .el$VERSION.sme\n" >> $RPM_BUILD_ROOT/etc/rpm/macros.disttag
printf %s%b "%" "el$VERSION 1\n" >> $RPM_BUILD_ROOT/etc/rpm/macros.disttag
printf %s%b "%" "__arch_install_post /usr/lib/rpm/check-buildroot\n" >> $RPM_BUILD_ROOT/etc/rpm/macros.checkbuild
#printf %s%b "%" "debug_package %%{nil}\n">> $RPM_BUILD_ROOT/etc/rpm/macros
#printf %s%b "%" "__debug_package 0\n ">> $RPM_BUILD_ROOT/etc/rpm/macros
%clean
rm -rf $RPM_BUILD_ROOT
%files
%defattr(-,root,root)
/etc/rpm/macros.disttag
/etc/rpm/macros.checkbuild
#/etc/rpm/macros
%changelog
* Tue Mar 12 2024 Jean-Philippe Pialasse <tests@pialasse.com> 8-3.sme
- remove __debug_package 0
* Tue Mar 12 2024 Jean-Philippe Pialasse <tests@pialasse.com> 8-1.sme
- up macro for el8
- add macro __debug_package 0
* Wed Jul 12 2023 BogusDateBot
- Eliminated rpmbuild "bogus date" warnings due to inconsistent weekday,
by assuming the date is correct and changing the weekday.
* Thu Jan 24 2013 Shad L. Lords <slords@mail.com> 6-1.sme
- Initial build.