daemontools-encore/daemontools-encore.spec
Jean-Philippe Pialasse 05ea95fdea * Mon Jan 20 2025 Jean-Philippe Pialasse <jpp@koozali.org> 1.10-5.sme
- fix cross compiling issues [SME: 12512]
- tidy spec from deprecated rhel version
2025-01-20 21:51:15 -05:00

102 lines
3.1 KiB
RPMSpec

Summary: A collection of tools for managing UNIX services
Name: daemontools-encore
Version: 1.10
Release: 5%{dist}
License: Public domain
Group: Utilities/System
URL: http://untroubled.org/daemontools-encore/
Source: http://untroubled.org/daemontools-encore/%{name}-%{version}.tar.gz
Source3: daemontools.service
Patch0: daemontools-encore-1.10-cross-compile.patch
Buildroot: %_tmppath/%{name}-%{version}
Obsoletes: daemontools
Provides: daemontools
BuildRequires: /usr/bin/perl
%define _build_id_links none
%define debug_package %{nil}
%description
daemontools-encore is a collection of tools for managing UNIX services.
It is derived from the public-domain release of daemontools by D. J.
Bernstein, which can be found at http://cr.yp.to/daemontools.html
daemontools-encore adds numerous enhancements above what daemontools
could do while maintaining backwards compatibility with daemontools.
See the CHANGES file for more details on what features have been added.
I realize there are other supervisory systems that will handle some or
all of the tasks that this package does better. I am providing this
package as a service to those who prefer the semantics and handling that
daemontools provides.
%prep
%setup
%patch0 -p1
perl -i -pe 'if ($. == 1) { s!^!%{buildroot}!; s!local/!! }' conf-bin
perl -i -pe 'if ($. == 1) { s!^!%{buildroot}!; s!local!share! }' conf-man
%build
CC="gcc $RPM_OPT_FLAGS -s " CFLAGS="$RPM_OPT_FLAGS" \
make
%install
mkdir -p %{buildroot}%{_bindir}
mkdir -p %{buildroot}%{_mandir}
DESTDIR=%{buildroot} make install
%if %{rhel} >= 7
mkdir -p %{buildroot}/usr/lib/systemd/system
install -m 0644 %{SOURCE3} %{buildroot}/usr/lib/systemd/system
%endif
mkdir -p %{buildroot}/service
# symlink executables to legacy SME directory
mkdir -p %{buildroot}/usr/local/bin
for prog in envdir envuidgid fghack multilog pgrphack readproctitle setlock setuidgid softlimit supervise svc svok svscan svscanboot svstat ; do
ln %{buildroot}/usr/bin/$prog %{buildroot}/usr/local/bin/$prog
done
%post
%if %{rhel} >= 7
if [ -e /usr/bin/systemctl ] ; then
systemctl enable daemontools
systemctl start daemontools
fi
%endif
%postun
if [ "$1" -eq 0 ]; then
%if %{rhel} >= 7
if [ -e /usr/bin/systemctl ] ; then
systemctl stop daemontools
systemctl disable daemontools
fi
%endif
fi
%files
%defattr(-,root,root)
%attr(0755,root,root) /usr/bin/*
/usr/share/man/man8/*
/usr/local/bin/*
%if %{rhel} >= 7
/usr/lib/systemd/system/daemontools.service
%endif
%dir %attr(0755,root,root) /service
%doc README CHANGES CHANGES.djb LICENSE TODO
%changelog
* Mon Jan 20 2025 Jean-Philippe Pialasse <jpp@koozali.org> 1.10-5.sme
- fix cross compiling issues [SME: 12512]
- tidy spec from deprecated rhel version
* Mon Jan 20 2025 Trevor Batley <trevorb@koozali.org> 1.10-4
- add debug_pkg %{nil} to remove empty debuginfo file error
- fix symlink of executables to legacy sme directory
* Thu Jan 16 2025 Trevor Batley <trevorb@koozali.org> 1.10-3
- check that systemctl exists in post install
- symlink executables to legacy sme directory
* Wed Feb 04 2015 Gavin Carr <gavin@openfusion.com.au> 1.10-1
- Initial package.