perl-Class-Method-Modifiers/perl-Class-Method-Modifiers.spec

113 lines
3.4 KiB
RPMSpec

# Run optional tests
%if ! (0%{?rhel})
%{bcond_without perl_Class_Method_Modifiers_enables_optional_test}
%else
%{bcond_with perl_Class_Method_Modifiers_enables_optional_test}
%endif
Name: perl-Class-Method-Modifiers
Version: 2.13
Release: 2%{?org_tag}%{?dist}
Summary: Provides Moose-like method modifiers
License: GPL+ or Artistic
Group: Development/Libraries
URL: http://search.cpan.org/dist/Class-Method-Modifiers/
Source0: http://localhost/cpan//authors/id/S/SA/SARTAK/Class-Method-Modifiers-%{version}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
# Module Build
BuildRequires: coreutils
BuildRequires: findutils
BuildRequires: make
BuildRequires: perl-interpreter
BuildRequires: perl-generators
BuildRequires: perl(ExtUtils::MakeMaker)
#BuildRequires: perl(ExtUtils::MakeMaker) >= 6.42
BuildRequires: perl(strict)
BuildRequires: perl(warnings)
# Module Runtime
BuildRequires: perl(B)
BuildRequires: perl(base)
BuildRequires: perl(Carp)
BuildRequires: perl(Exporter)
# Test Suite
BuildRequires: perl(File::Spec)
BuildRequires: perl(if)
BuildRequires: perl(Test::Fatal)
BuildRequires: perl(Test::More) >= 0.88
BuildRequires: perl(Test::Requires)
BuildRequires: perl(Test::Needs)
BuildRequires: perl(version)
# Optional Test Requirements
%if 0%{!?perl_bootstrap:1} && %{with perl_Class_Method_Modifiers_enables_optional_test}
BuildRequires: perl(CPAN::Meta::Requirements) >= 2.121
BuildRequires: perl(CPAN::Meta) >= 2.120900
BuildRequires: perl(Moose)
%endif
# Runtime
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
Requires: perl(B)
Requires: perl(Carp)
Requires: perl(Exporter)
%description
Method modifiers are a powerful feature from the CLOS (Common Lisp Object
System) world.
In its most basic form, a method modifier is just a method that calls
'$self->SUPER::foo(@_)'. I for one have trouble remembering that exact
invocation, so my classes seldom re-dispatch to their base classes. Very
bad!
'Class::Method::Modifiers' provides three modifiers: 'before', 'around',
and 'after'. 'before' and 'after' are run just before and after the method
they modify, but can not really affect that original method. 'around' is
run in place of the original method, with a hook to easily call that
original method. See the 'MODIFIERS' section for more details on how the
particular modifiers work.
%prep
%setup -q -n Class-Method-Modifiers-%{version}
# Drop unnecessary exec permissions from test files
chmod -c -x t/*.t
%build
perl Makefile.PL INSTALLDIRS=vendor
make %{?_smp_mflags}
%install
rm -rf %{buildroot}
make pure_install PERL_INSTALL_ROOT=%{buildroot}
find %{buildroot} -type f -name .packlist -exec rm -f {} \;
find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null \;
%{_fixperms} %{buildroot}/*
%check
make test
%clean
rm -rf %{buildroot}
%files
%defattr(-,root,root,-)
%doc Changes
%{perl_vendorlib}/*
%{_mandir}/man3/*
%changelog
* Thu Jan 23 2025 Jean-Philippe Pialasse <jpp@koozali.org> 2.13-2.sme
- import to SME11
* Fri Nov 27 2020 Gavin Carr <gavin@openfusion.com.au> 2.13-1
- Update to version 2.13.
* Fri Aug 08 2014 Gavin Carr <gavin@openfusion.com.au> 2.10-1
- Update to version 2.10.
* Fri Aug 12 2011 Gavin Carr <gavin@openfusion.com.au> 1.07-1
- Specfile autogenerated by cpanspec 1.79.