76 lines
2.2 KiB
RPMSpec
76 lines
2.2 KiB
RPMSpec
Name: perl-File-chmod
|
|
Version: 0.42
|
|
Release: 1%{?dist}
|
|
Summary: Implements symbolic and ls chmod modes
|
|
License: GPL+ or Artistic
|
|
Group: Development/Libraries
|
|
URL: http://search.cpan.org/dist/File-chmod/
|
|
Source0: http://www.cpan.org/authors/id/X/XE/XENO/File-chmod-%{version}.tar.gz
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
|
BuildArch: noarch
|
|
BuildRequires: perl >= 0:5.006
|
|
BuildRequires: perl(autodie)
|
|
BuildRequires: perl(base)
|
|
BuildRequires: perl(Carp)
|
|
BuildRequires: perl(English)
|
|
BuildRequires: perl(Exporter)
|
|
BuildRequires: perl(ExtUtils::MakeMaker)
|
|
BuildRequires: perl(File::Spec)
|
|
BuildRequires: perl(File::Temp)
|
|
BuildRequires: perl(IO::Handle)
|
|
BuildRequires: perl(IPC::Open3)
|
|
BuildRequires: perl(strict)
|
|
BuildRequires: perl(Test::More)
|
|
BuildRequires: perl(utf8)
|
|
BuildRequires: perl(vars)
|
|
BuildRequires: perl(warnings)
|
|
Requires: perl(base)
|
|
Requires: perl(Carp)
|
|
Requires: perl(Exporter)
|
|
Requires: perl(strict)
|
|
Requires: perl(vars)
|
|
Requires: perl(warnings)
|
|
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
|
|
Provides: perl(File::chmod)
|
|
|
|
%description
|
|
File::chmod is a utility that allows you to bypass system calls or bit
|
|
processing of a file's permissions. It overloads the chmod() function with
|
|
its own that gets an octal mode, a symbolic mode (see below), or an "ls"
|
|
mode (see below). If you wish not to overload chmod(), you can export
|
|
symchmod() and lschmod(), which take, respectively, a symbolic mode and an
|
|
"ls" mode.
|
|
|
|
%prep
|
|
%setup -q -n File-chmod-%{version}
|
|
|
|
%build
|
|
%{__perl} Makefile.PL INSTALLDIRS=vendor
|
|
make %{?_smp_mflags}
|
|
|
|
%install
|
|
rm -rf $RPM_BUILD_ROOT
|
|
|
|
make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
|
|
|
|
find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \;
|
|
find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \;
|
|
|
|
%{_fixperms} $RPM_BUILD_ROOT/*
|
|
|
|
%check
|
|
make test
|
|
|
|
%clean
|
|
rm -rf $RPM_BUILD_ROOT
|
|
|
|
%files
|
|
%defattr(-,root,root,-)
|
|
%doc Changes CONTRIBUTING LICENSE META.json perlcritic.rc README
|
|
%{perl_vendorlib}/*
|
|
%{_mandir}/man3/*
|
|
|
|
%changelog
|
|
* Sat Feb 17 2024 Trevor Batley <trevor@batley.id.au> 0.42-1
|
|
- Specfile autogenerated by cpanspec 1.78.
|