You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
perl-Object-Persistence/perl-Object-Persistence.spec

203 lines
6.6 KiB
Plaintext

# $Id: perl-Object-Persistence.spec,v 1.8 2023/06/04 13:22:15 brianr Exp $
#
# - Object-Persistence -
# This spec file was automatically generated by cpan2rpm [ver: 2.026]
# The following arguments were used:
# --no-requires=Crypt::Random --release=3 Persistence::Object::Simple
# For more information on cpan2rpm please visit: http://perl.arix.com/
#
%define pkgname Object-Persistence
%define filelist %{pkgname}-%{version}-filelist
%define NVR %{pkgname}-%{version}-%{release}
%define maketest 1
%define custom_find_req %{_tmppath}/%{NVR}-find-requires
%define _use_internal_dependency_generator 0
%define __find_requires %{custom_find_req}
%define __perl_requires %{custom_find_req}
name: perl-Object-Persistence
summary: Object-Persistence - Object Persistence with Data::Dumper.
version: 0.92
release: 8%{?dist}
license: Artistic
group: Applications/CPAN
url: http://www.cpan.org
buildroot: %{_tmppath}/%{name}-%{version}-%(id -u -n)
buildarch: noarch
prefix: %(echo %{_prefix})
source: http://search.cpan.org/dist/V/VI/VIPUL/Object-Persistence-0.92.tar.gz
Patch0: %{pkgname}-%{version}.patch.2002052300
Patch1: %{pkgname}-%{version}.patch.2004092700
Patch2: %{pkgname}-%{version}.patch.forceDumpperl
BuildRequires: perl(ExtUtils::MakeMaker)
BuildRequires: perl(ExtUtils::ParseXS)
BuildRequires: perl(ExtUtils::Manifest)
BuildRequires: perl(Digest::MD5)
BuildRequires: perl(Data::Dumper)
%description
P::O::S provides persistence functionality to its objects. Object definitions
are stored as stringified perl data structures, generated with Data::Dumper,
that are amenable to manual editing and external processing from outside the
class interface.
Persistence is achieved with a blessed hash container that holds the object
data. The container can store objects that employ non-hash structures as
well. See L<"Inheriting Persistence::Object::Simple">, L<"Class Methods"> and
the persistent list class example (examples/Plist.pm).
#
# This package was generated automatically with the cpan2rpm
# utility. To get this software or for more information
# please visit: http://perl.arix.com/
#
%prep
%setup -q -n %{pkgname}-%{version}
chmod -R u+w %{_builddir}/%{pkgname}-%{version}
%patch0 -p1
%patch1 -p1
%patch2 -p1
%build
grep -rsl '^#!.*perl' . |
grep -v '.bak$' |xargs --no-run-if-empty \
%__perl -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)'
CFLAGS="$RPM_OPT_FLAGS"
%{__perl} Makefile.PL `%{__perl} -MExtUtils::MakeMaker -e ' print qq|PREFIX=%{buildroot}%{_prefix}| if \$ExtUtils::MakeMaker::VERSION =~ /5\.9[1-6]|6\.0[0-5]/ '`
%{__make}
%if %maketest
%{__make} test
%endif
%install
[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
cat <<EOF > %{custom_find_req}
#!/bin/sh
/usr/lib/rpm/find-requires |grep -v -e 'Crypt::Random'
EOF
chmod 755 %{custom_find_req}
%{makeinstall} `%{__perl} -MExtUtils::MakeMaker -e ' print \$ExtUtils::MakeMaker::VERSION <= 6.05 ? qq|PREFIX=%{buildroot}%{_prefix}| : qq|DESTDIR=%{buildroot}| '`
[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
# SuSE Linux
if [ -e /etc/SuSE-release -o -e /etc/UnitedLinux-release ]
then
%{__mkdir_p} %{buildroot}/var/adm/perl-modules
%{__cat} `find %{buildroot} -name "perllocal.pod"` \
| %{__sed} -e s+%{buildroot}++g \
> %{buildroot}/var/adm/perl-modules/%{name}
fi
# remove special files
find %{buildroot} -name "perllocal.pod" \
-o -name ".packlist" \
-o -name "*.bs" \
|xargs -i rm -f {}
# no empty directories
find %{buildroot}%{_prefix} \
-type d -depth \
-exec rmdir {} \; 2>/dev/null
%{__perl} -MFile::Find -le '
find({ wanted => \&wanted, no_chdir => 1}, "%{buildroot}");
print "%doc Changes examples";
for my $x (sort @dirs, @files) {
push @ret, $x unless indirs($x);
}
print join "\n", sort @ret;
sub wanted {
return if /auto$/;
local $_ = $File::Find::name;
my $f = $_; s|^\Q%{buildroot}\E||;
return unless length;
return $files[@files] = $_ if -f $f;
$d = $_;
/\Q$d\E/ && return for reverse sort @INC;
$d =~ /\Q$_\E/ && return
for qw|/etc %_prefix/man %_prefix/bin %_prefix/share|;
$dirs[@dirs] = $_;
}
sub indirs {
my $x = shift;
$x =~ /^\Q$_\E\// && $x ne $_ && return 1 for @dirs;
}
' > %filelist
[ -z %filelist ] && {
echo "ERROR: empty %files listing"
exit -1
}
%clean
[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
rm -f %{custom_find_req}
%files -f %filelist
%defattr(-,root,root)
%changelog
* Mon Mar 11 2024 Jean-Philippe Pialasse <tests@pialasse.com> - 0.92-8.sme
- build for SME 11
* Fri Jul 14 2023 BogusDateBot
- Eliminated rpmbuild "bogus date" warnings due to inconsistent weekday,
by assuming the date is correct and changing the weekday.
* Sun Jun 04 2023 brian Read <brianr@koozali.org> - 0.92-7.sme
- add manifest.pm to Requirerments [SME: 12364]
* Tue Feb 9 2016 Daniel Berteaud <daniel@firewall-services.com> - 0.92-6.sme
- Add correct BuildReq so it can build on el7 [SME: 9210]
* Sun Feb 7 2016 stephane de labrusse <stephdl@de-labrusse.fr> 0.92-5.sme
- Build new rpm for sme10
* Wed Sep 9 2015 Daniel Berteaud <daniel@firewall-services.com> - 0.92-5.sme
- Add correct BuildReq so it can build on el6 [SME: 8887]
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
- Clean up spec so package can be built by koji/plague
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com>
- Update to new release naming. No functional changes.
- Make Packager generic
* Wed Sep 13 2006 Michael Soulier <michael_soulier@mitel.com>
- Forced Data::Dumper to use Dumpperl to work around interpreter crash.
[sme 1837]
* Mon Sep 27 2004 Charlie Brady <charlieb@e-smith.com>
- [0.92-3es01]
- Remove "AutoReqProv: no" so that rpmbuild calculates proper
provides. Remove Provides header thus made redudent.
[charlieb MN00040240]
- Fix croak in Simple.pm so that problems with cache file opens
are reported [charlieb ]
- Use new cpan2rpm template for build (for compat with CentOS).
* Wed Sep 22 2004 Michael Soulier <michael_soulier@mitel.com>
- [0.92-2es01]
- Rebuilding to get proper provides. [msoulier MN00040240]
* Thu May 23 2002 Mark Knox <markk@e-smith.com>
- [0.92-2]
- Changed untaint to slurp in all contents of temp file in order to prevent
semicolons in values from corrupting the session. [markk 3630]
* Mon Feb 18 2002 Charlie Brady <charlieb@e-smith.com>
- Upgrade to version 0.92 (received by email).
* Mon Feb 26 2001 Tony Clayton <tonyc@e-smith.com>
- initial release