You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

99 lines
3.0 KiB
Plaintext

# $Id: perl-Quota.spec,v 1.4 2023/07/24 22:25:07 trevorb Exp $
# Authority: shuff
# Upstream: Tom Zoerner <tomzo$users,sourceforge,net>
%define perl_vendorlib %(eval "`%{__perl} -V:installvendorlib`"; echo $installvendorlib)
%define perl_vendorarch %(eval "`%{__perl} -V:installvendorarch`"; echo $installvendorarch)
%define real_name Quota
Summary: Perl interface to file system quotas
Name: perl-Quota
Version: 1.8.2
Release: 1%{?dist}
License: Artistic/GPL
Group: Applications/CPAN
URL: http://search.cpan.org/dist/Quota/
Packager: Steve Huff <shuff@vecna.org>
Vendor: Dag Apt Repository, http://dag.wieers.com/apt/
Source: http://www.cpan.org/modules/by-module/Quota/Quota-%{version}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildRequires: perl
BuildRequires: perl(ExtUtils::MakeMaker)
BuildRequires: perl(ExtUtils::Manifest)
BuildRequires: perl(ExtUtils::ParseXS)
BuildRequires: quota quota-devel
%description
The Quota module provides access to file system quotas. The
quotactl system call or ioctl is used to query or set quotas
on the local host, or queries are submitted via RPC to a
remote host. Mount tables can be parsed with getmntent and
paths can be translated to device files (or whatever the
actual quotactl implementations needs as argument) of the
according file system.
%prep
%setup -n %{real_name}-%{version}
%build
CFLAGS="%{optflags} -fPIC" %{__perl} Makefile.PL INSTALLDIRS="vendor" PREFIX="%{buildroot}%{_prefix}"
%{__make} %{?_smp_mflags} OPTIMIZE="%{optflags} -fPIC"
%install
%{__rm} -rf %{buildroot}
%{__make} pure_install
### Clean up buildroot
find %{buildroot} -name .packlist -exec %{__rm} {} \;
### Clean up docs
find contrib/ -type f -exec %{__chmod} a-x {} \;
%clean
%{__rm} -rf %{buildroot}
%files
%defattr(-, root, root, 0755)
%doc CHANGES INSTALL MANIFEST META.yml README contrib/
%doc %{_mandir}/man3/Quota.3pm*
%{perl_vendorarch}/auto/Quota/
%{perl_vendorarch}/Quota.pm
%changelog
* Thu Oct 26 2023 BogusDateBot
- Eliminated rpmbuild "bogus date" warnings due to inconsistent weekday,
by assuming the date is correct and changing the weekday.
* Tue Jul 25 2023 Trevor Batley <trevor@batley.id.au> - 1.8.2-1.sme
- Update to latest version 1.8.2 [SME: 12386]
- add additional perl modules in BuildRequires
* Fri Feb 1 2013 Shad L. Lords <slords@mail.com> - 1.6.7-2.sme
- Add buildrequires so building on rhel6 works [SME: 7253]
* Fri Apr 13 2012 Steve Huf <shuff@vecna.org> - 1.6.7-1
- Updated to version 1.6.7.
* Wed Jul 22 2009 Christoph Maser <cmr@financial.com> - 1.6.3-1
- Updated to version 1.6.3.
* Wed Jan 23 2008 Dag Wieers <dag@wieers.com> - 1.6.2-1
- Updated to release 1.6.2.
* Tue Dec 04 2007 Dag Wieers <dag@wieers.com> - 1.6.1-1
- Updated to release 1.6.1.
* Sun Nov 18 2007 Dag Wieers <dag@wieers.com> - 1.6.0-1
- Updated to release 1.6.0.
* Sat Nov 5 2005 Dries Verachtert <dries@ulyssis.org> - 1.5.1-1
- Updated to release 1.5.1.
* Wed Dec 08 2004 Dries Verachtert <dries@ulyssis.org> - 1.5.0
- Initial package.